Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-46743

Task "send new user password" not working

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Duplicate
    • 2.7.1
    • None
    • Authentication
    • None
    • MOODLE_27_STABLE

    Description

      When I upload a .csv file to create new user accounts (not containing a password column), the new accounts are created and the report tells me that passwords have been generated by cron, but they are not sent to the users - the new users don't get any emails.

      Same when I try to use the bulk user actions "confirm" or "force password change": No mails are being sent out to the users.
      However, when I use the regular user creation form for single users (activating "create password and send notification"), it does work - an email is sent to the user right away. Also, the message function in bulk user actions works as expected, so I am sure my mail settings are okay.

      Additional note: In "server > scheduled tasks" the execution of "send new user password" apparently is not completed: When the scheduled time is reached, the "next run" is postponed, first by a minute, later by a whole day, and in the "fail delay" column I find "86400". The "last run" date/time always stays the same, so apparently the task has not been executed or completed.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              dogel Johannes Prischl
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Sujith Haridasan
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: