Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-47651

Quiz responses report can give a fatal error with unusual question types

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.7.2
    • Fix Version/s: 2.7.3
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      Hide

      I have just tested this, and it is almost impossible for anyone else to test the case where the bug occurred.

      It would be worth someone independent testing for regressions:

      1. Creat a quiz with Behaviour 'Interactive with multiple tries'
      2. Create a short-answer question with two hints.
      3. Add the short-answer question to the quiz.
      4. As a student, attempt the quiz, getting the question wrong twice, tehn right.
      5. As teacher, go to Results -> Responses, and choose to show all Tries.
      6. Verify that you can see all three responses that you tried as a student.
      Show
      I have just tested this, and it is almost impossible for anyone else to test the case where the bug occurred. It would be worth someone independent testing for regressions: Creat a quiz with Behaviour 'Interactive with multiple tries' Create a short-answer question with two hints. Add the short-answer question to the quiz. As a student, attempt the quiz, getting the question wrong twice, tehn right. As teacher, go to Results -> Responses, and choose to show all Tries. Verify that you can see all three responses that you tried as a student.
    • Affected Branches:
      MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_27_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      If a question in the quiz is of a type that does not implement the interface question_manually_gradable, then the call to summarise_response in mod/quiz/report/responses/first_or_all_responses_table.php would cause a fatal error.

      (I only found this because the add-on qtype_opaque was incorrectly subclassing question_definition, not question_with_responses.

      Still, having found this, I would like to see the fix integrated.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                timhunt Tim Hunt
                Reporter:
                timhunt Tim Hunt
                Peer reviewer:
                Tim Hunt
                Integrator:
                Dan Poltawski
                Tester:
                Zachary Durber
                Participants:
                Component watchers:
                Tim Hunt, Andrew Nicols, Mathew May, Michael Hawkins, Shamim Rezaie, Simey Lameze
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Nov/14