Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-47755

Badge message when viewed internally has more <br> than it should

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.7.2
    • Fix Version/s: 2.6.6, 2.7.3
    • Component/s: Badges, Messages
    • Labels:
    • Testing Instructions:
      Hide

      To test you need a user who can earn a badge (User 1) and a user who can create a badge (User 2).

      1. As User 2 create a simple badge that can be issued manually.
      2. As User 2 change badge message to some long text containing several paragraphs.
      3. Make sure that User 1 has a valid email and can get internal messages and emails (check message settings for User 1, default settings usually work fine)
      4. As User 2 issue a badge to User 1.
        1. Just in case run cron (messages might be sent out on cron).
      5. Log in as User 1 and check your messages under Home > My profile > Messages.
      6. There should be a message from either admin user or badge issuer set in badge details (depends on your site settings).
      7. Make sure that formatting is correct, no lines are being broken when they should not be (initial issue is that line breaks were set every 80 character).
      8. Check User 1's email and make sure that email is displayed correctly as well, no lines are being broken when they should not be.
      Show
      To test you need a user who can earn a badge (User 1) and a user who can create a badge (User 2). As User 2 create a simple badge that can be issued manually. As User 2 change badge message to some long text containing several paragraphs. Make sure that User 1 has a valid email and can get internal messages and emails (check message settings for User 1, default settings usually work fine) As User 2 issue a badge to User 1. Just in case run cron (messages might be sent out on cron). Log in as User 1 and check your messages under Home > My profile > Messages. There should be a message from either admin user or badge issuer set in badge details (depends on your site settings). Make sure that formatting is correct, no lines are being broken when they should not be (initial issue is that line breaks were set every 80 character). Check User 1's email and make sure that email is displayed correctly as well, no lines are being broken when they should not be.
    • Affected Branches:
      MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_26_STABLE, MOODLE_27_STABLE
    • Pull Master Branch:
      MDL-47755_master

      Description

      The Badge message sent by email is fine and respect the way the teacher composed it.

      But when viewed in the internal message system, the message has <br> not added by the creator. Hence the message is not well displayed.

      I made a check on demo.moodle.net to confirm that the problem is not specific to our Moodle.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                10/Nov/14