Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-47908

Forum discussion subscribe problem with links in the email

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.8, Future Dev
    • Fix Version/s: None
    • Component/s: Forum
    • Labels:
    • Affected Branches:
      MOODLE_28_STABLE

      Description

      Steps to reproduce: (this is how I found it. you probably want to use your test server.)

      1. Go to https://moodle.org/mod/forum/view.php?f=1048
      2. Verify that you are not subscribed to the forum as a whole.
      3. Reply to one of the discussions there, chooseing to subscribe to the discussion.
      4. Wait for the email to arrive.
      5. Note that it says "Unsubscribe from this forum: https://moodle.org/mod/forum/subscribe.php?id=1048" near the end.
      6. Click that link.
      7. Note that you are now on a page saying "Do you really want to subscribe to forum 'Security and privacy'?"

      That is wrong.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dobedobedoh Andrew Nicols
              Reporter:
              timhunt Tim Hunt
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: