Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-47979

blocks with has_config(true) and no settings.php displays link to invalid page

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.6.5, 2.7.2, 2.8, 2.9.3, 3.0
    • Fix Version/s: 2.9.4
    • Component/s: Blocks

      Description

      admin/block.php was the old settings link we used to have before we introduced settings.php support for blocks ages ago. We used to support both old style config.html and settings.php - but now you must include a settings.php.

      So that link should be removed (and probably replaced with a debugging message saying 'cant find settings.php' or something like that).

      Steps to reproduce:

      1. mv block/rss_client/settings.php block/rss_client/settings1.php
      2. Visit Site administration / ▶ Plugins / ▶ Blocks / ▶ Manage blocks
      3. Click the link to settings on RSS block

      Observe that the link doesn't exist.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mudrd8mz David Mudrák (@mudrd8mz)
              Reporter:
              poltawski Dan Poltawski
              Peer reviewer:
              Dan Poltawski
              Integrator:
              Eloy Lafuente (stronk7)
              Tester:
              John Okely
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                11/Jan/16