Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-48004

Call to a member function all() on a non-object

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.6.5, 2.9.3
    • Fix Version/s: 2.9.4, 3.0.1
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      Hide
      1. Visit moodle/question/import.php - ensure it does not throw a php error
      2. Run all quiz/question behat tests
      3. Create and export some questions from the question bank
      4. Import a question at course level, repeat at quiz level
      5. Change question context to system and repeat
      6. Grep the code for any import.php links without courseid or cmid being passed
      Show
      Visit moodle/question/import.php - ensure it does not throw a php error Run all quiz/question behat tests Create and export some questions from the question bank Import a question at course level, repeat at quiz level Change question context to system and repeat Grep the code for any import.php links without courseid or cmid being passed
    • Affected Branches:
      MOODLE_26_STABLE, MOODLE_29_STABLE
    • Fixed Branches:
      MOODLE_29_STABLE, MOODLE_30_STABLE
    • Pull Master Branch:
      MDL-48004-master

      Description

      Hello, I have error in apache error log:

      [Tue Oct 28 08:14:01 2014] [error] [client 72.14.199.31] PHP Fatal error: Call to a member function all() on a non-object in /var/www/moodle.site/moodle/question/editlib.php on line 1718

      From acces log:

      moodle.site:443 72.14.199.31 - - [28/Oct/2014:08:14:01 +0000] "GET /question/import.php HTTP/1.1" 500 5689 "-" "AdsBot-Google (+http://www.google.com/adsbot.html)"

      It's appears after upgrade from 2.4.11 to 2.6.5, if need any more information about my environment, write back to me.

      OS: Debian 6, php: 5.3.3 from debian, Mysql: 5.5.38-1~dotdeb.0-log, Apache/2.2.16

      Find some demo moodle in internet, seems not only mine problem:

      curl -I http://moodle.mylearningspace.com.au/question/import.php
      HTTP/1.1 500 Internal Server Error

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                21/Dec/15