Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-48094

Behat test failing to log in when run after others, but passes when run alone

    XMLWordPrintable

Details

    • MOODLE_27_STABLE, MOODLE_28_STABLE

    Description

      I thought I had simple steps to reproduce here, but it is obviously not as simple as I thought.

      Install multiple OU question types into a master install:

      • qtype_combined
      • qtype_ddimageortext
      • qtype_gapselect
      • qtype_oumultiresponse
      • qtype_pmatch
      • qtype_varnumericset
      • qtype_varnumeric

      Run the Behat tests for --tags qtype_combined,qtype_ddimageortext

      You will see two failures. The first one in qtype_combined is a known issue. The interesting one is the qtype_ddimageortext one. Now run that test alone: ..../question\type\ddimageortext\tests\behat\basic_test.feature. It passes.

      So, something from the previous test is breaking this following test, which should not happen, but I can't work out what, and simpler examples do not break.

      Obviously each scenario should be independent.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              timhunt Tim Hunt
              Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: