Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-48328

lessc is failing to compile our less

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.1
    • Fix Version/s: 2.9
    • Component/s: Themes
    • Testing Instructions:
      Hide
      1. Compile Bootstrapbase LESS using
        • lessc moodle.less > ../style/moodle.css
        • recess
        • a recent GUI client that you find on the net (e.g. CodeKit)
      2. Customise More theme and confirm your styles were applied
      Show
      Compile Bootstrapbase LESS using lessc moodle.less > ../style/moodle.css recess a recent GUI client that you find on the net (e.g. CodeKit) Customise More theme and confirm your styles were applied
    • Affected Branches:
      MOODLE_28_STABLE
    • Fixed Branches:
      MOODLE_29_STABLE
    • Pull Master Branch:
      MDL-48328_M29

      Description

      I'm a bit clueless, so I don't know what this means at the moment, but it doesn't look like a good sign if one compilier can't compile our less..

      danp@lisa:~/www/im/theme/bootstrapbase/less (master *)$ lessc moodle.less > ../style/moodle.css
      NameError: #grid > .core > .span is undefined in /Users/danp/moodles/im/moodle/theme/bootstrapbase/less/bootstrap/navbar.less on line 199, column 3:
      198 .navbar-fixed-bottom .container {
      199   #grid > .core > .span(@gridColumns);
      200 }
      

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/May/15