Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-48338

"A single simple discussion" Forum doesn't scroll to new posts

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8, 2.9, 3.0, 3.1, 3.3.3, 3.4, 3.5.3
    • Fix Version/s: 3.5.5, 3.6.3
    • Component/s: Forum
    • Testing Instructions:
      Hide
      1. Login as Administrator
      2. Create a course
      3. Create a new user, and enrol the user in the course
      4. Login as your new user
      5. Open User menu -> Preferences -> Forum preferences
        1. Enable read-tracking of forums
      6. Login as Admin
      7. In the course add the following new forums:
        1. Standard
        2. Single simple discussion
      8. Create a new discussion in each of the forums
      9. Add the "Activities" block to the course.
      10. Login as your other user
      11. From the Activities block, click the "Forums" link.
        1. Confirm that there are "1 unread post" links beneath each of the forums
        2. Confirm that the URL for each of these ends in '#unread'
      12. View the course page
        1. Confirm that there are "1 unread post" links beneath each of the forums
        2. Confirm that the URL for each of these ends in '#unread'
      13. Click on the "1 unread post" link for the Single simple discussion forum
        1. Confirm that you are taken to the first unread post in the forum
      Show
      Login as Administrator Create a course Create a new user, and enrol the user in the course Login as your new user Open User menu -> Preferences -> Forum preferences Enable read-tracking of forums Login as Admin In the course add the following new forums: Standard Single simple discussion Create a new discussion in each of the forums Add the "Activities" block to the course. Login as your other user From the Activities block, click the "Forums" link. Confirm that there are "1 unread post" links beneath each of the forums Confirm that the URL for each of these ends in ' #unread ' View the course page Confirm that there are "1 unread post" links beneath each of the forums Confirm that the URL for each of these ends in ' #unread ' Click on the " 1 unread post " link for the Single simple discussion forum Confirm that you are taken to the first unread post in the forum
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_28_STABLE, MOODLE_29_STABLE, MOODLE_30_STABLE, MOODLE_31_STABLE, MOODLE_33_STABLE, MOODLE_34_STABLE, MOODLE_35_STABLE
    • Fixed Branches:
      MOODLE_35_STABLE, MOODLE_36_STABLE
    • Pull 3.5 Branch:
    • Pull 3.6 Branch:
    • Pull Master Branch:
      MDL-48338-master

      Description

      Hi,
      "Standard forum for general use" when there are new posts scrolls down to first new post.

      But "A single simple discussion" Forum doesn't

      There is a missing "#unread" part in URL.

        Attachments

        1. 1.png
          1.png
          21 kB
        2. 2.png
          2.png
          19 kB
        3. screenshot-1.png
          screenshot-1.png
          213 kB

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Mar/19

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 30 minutes
                  30m