Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-48396

Creating lesson question with image in answer throw exception

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.7.3, 2.8.1
    • Fix Version/s: None
    • Component/s: Lesson
    • Labels:
    • Affected Branches:
      MOODLE_27_STABLE, MOODLE_28_STABLE

      Description

      Steps to reproduce:

      1. Create a lesson activity
      2. Add question by clicking on "Add a question page"
      3. Select "Multichoice" question
      4. Click on image icon in "Answer 1" or "Answer 2" editor
      5. You will see following error in apache log.
        [Thu Nov 27 16:22:22.148856 2014] [:error] [pid 1744] [client 127.0.0.1:41026] Default exception handler: A required parameter (pageid) was missing Debug: \nError code: missingparam\n* line 463 of /lib/setuplib.php: moodle_exception thrown\n* line 548 of /lib/moodlelib.php: call to print_error()\n* line 31 of /mod/lesson/editpage.php: call to required_param()\n, referer: http://rajesh.in.moodle.com/im/mod/lesson/editpage.php
        

      Can also be reproduced by running behat with --name "In a lesson activity, teacher can add embedded images in questions answers and responses" and looking at error log

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: