Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-48419

Scorm network check too agressive

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Add a scorm package
      2. View the package in the player (e.g. as a student would)
      3. Open the JS Console and keep an eye on the console
      4. Wait for 20-30 seconds
      5. Shut your web server down (e.g. service apache2 stop)
      6. Switch back to your browser - DO NOT REFRESH
      7. Wait 20-30 seconds
        • Confirm that an alert was shown
      8. Restart your web server - DO NOT REFRESH
      9. Wait 20-30 seconds
        • Confirm that the alert disappeared
        • Remove /lib/yui/build/moodle-core-checknet/assets/checknet.txt
      10. Wait 20-30 seconds
        • Confirm that an alert was shown
      11. Click the 'Ok' button
      12. Wait a few seconds
        • Confirm that an alert was shown again
      13. Place the file back
      14. Wait 20-30 seconds
        • Confirm that the alert disappeared
      Show
      Add a scorm package View the package in the player (e.g. as a student would) Open the JS Console and keep an eye on the console Wait for 20-30 seconds Shut your web server down (e.g. service apache2 stop) Switch back to your browser - DO NOT REFRESH Wait 20-30 seconds Confirm that an alert was shown Restart your web server - DO NOT REFRESH Wait 20-30 seconds Confirm that the alert disappeared Remove /lib/yui/build/moodle-core-checknet/assets/checknet.txt Wait 20-30 seconds Confirm that an alert was shown Click the 'Ok' button Wait a few seconds Confirm that an alert was shown again Place the file back Wait 20-30 seconds Confirm that the alert disappeared
    • Affected Branches:
      MOODLE_27_STABLE
    • Fixed Branches:
      MOODLE_27_STABLE, MOODLE_28_STABLE
    • Pull Master Branch:
      master_MDL-48419

      Description

      My 25 lessons course was published with Moodle 2.7.2. Opening any lesson appears the following alert "The SCORM player has determined that your Internet connection is unreliable or has been interrupted. If you continue in this SCORM activity, your progress may not be saved. You should exit the activity now, and return when you have a dependable Internet connection". The same alert appears again several times.
      My connection is OK. The same problem happened in an another computer far away.
      What do you suggest, upgrade to Moodle 2.8 or downgrade to Moodle 2.6.5 ?
      The Moodle version is 2.7.2 build 20140908

      Thanks for helping
      Maurício

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                5 Vote for this issue
                Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/May/15