Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-48449

Epic: Collect together deprecated and planned code changes for Moodle 3.1

    XMLWordPrintable

    Details

    • Type: Epic
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 2.9
    • Fix Version/s: None
    • Component/s: General
    • Labels:
    • Affected Branches:
      MOODLE_29_STABLE
    • Epic Name:
      3.1 deprecations

      Description

      In 3.1 we can remove functionality that was deprecated in 2.9 or earlier (see MDL-52663)

      There are a number of parts of the Moodle codebase that have been marked as deprecated as a warning to developers not to use these functions as they will be removed in future. Many have a deadline of 3.1.

      Each of these deprecated functions, especially those in Moodle core code, should have an MDL issue associated with it.

      In order to time the removal of these deprecated functio issues and not lose sight of them, this issue will be used to collect them together.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                marina Marina Glancy
                Participants:
                Component watchers:
                Jake Dallimore, Jun Pataleta, Ryan Wyllie
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: