Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-48608

Group assignments not showing grade in assignment page without a submission

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.3
    • Fix Version/s: 2.8.4
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      Hide
      Test 1
      1. Go to a course that has at least one enrolled student.
      2. Create an assignment with the setting 'Students submit in groups' set to 'Yes'.
      3. Click to view the assignment click on the 'View/grade all submissions'.
      4. Grade a user via quick-grading.
      5. Check that the grade input box displays the grade.
      6. Repeat the above but instead make sure 'Students submit in groups' is set to 'No'.
      Test 2
      1. Run the behat tests with the tag @mod_assign and ensure all pass.
      Show
      Test 1 Go to a course that has at least one enrolled student. Create an assignment with the setting 'Students submit in groups' set to 'Yes'. Click to view the assignment click on the 'View/grade all submissions'. Grade a user via quick-grading. Check that the grade input box displays the grade. Repeat the above but instead make sure 'Students submit in groups' is set to 'No'. Test 2 Run the behat tests with the tag @mod_assign and ensure all pass.
    • Affected Branches:
      MOODLE_28_STABLE
    • Fixed Branches:
      MOODLE_28_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-48608_master
    • Sprint:
      Team B Sprint 1, Team Beards Sprint 2
    • Issue size:
      Small

      Description

      Reproduction steps:

      • Create assignment.
        • Under "Group submission settings" set "Students submit in groups" to "Yes".
      • Save and display.
      • Go to View/grade all submissions.
      • Grade a user, either via quick-grading or editing the grade.
      • Grade will be empty. (although if you click edit, you will see the grade was saved)

      If you login as a user and submit something, tada! your grade is now there.

      This appears to be a visual bug introduced since 2.8 as I've tested on 2.7 and she's fine.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              markn Mark Nelson
              Reporter:
              zac Zachary Durber
              Peer reviewer:
              Damyon Wiese
              Integrator:
              Andrew Nicols
              Tester:
              Frédéric Massart
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                9/Mar/15