Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-49271

update from 2.6 to 2.8

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.6.8
    • Fix Version/s: None
    • Component/s: Installation, Tags
    • Labels:
    • Affected Branches:
      MOODLE_26_STABLE

      Description

      Hi
      I have a problem whith the update moodle 2.6 to 2.8. During the update moodle sytem show error

      Debug info: Subquery returns more than 1 row
      UPDATE mdl_tag_instance
      SET component = 'core',
      contextid = (SELECT ctx.id
      FROM mdl_context ctx
      WHERE ctx.contextlevel = ?
      AND ctx.instanceid = mdl_tag_instance.itemid)
      WHERE itemtype = 'user' AND contextid IS NULL
      [array (
      0 => 30,
      )]
      Error code: dmlwriteexception
      Stack trace:
      line 446 of /lib/dml/moodle_database.php: dml_write_exception thrown
      line 974 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
      line 3280 of /lib/db/upgrade.php: call to mysqli_native_moodle_database->execute()
      line 1560 of /lib/upgradelib.php: call to xmldb_main_upgrade()
      line 361 of /admin/index.php: call to upgrade_core()

      Need your help
      thanks

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              semdm Semen
              Participants:
              Component watchers:
              Matteo Scaramuccia, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: