Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-49385

block_base: config_save needs to marked as deprecated

    XMLWordPrintable

    Details

      Description

      block_base->config_save does not seem used anywhere any more. It needs to be marked as deprecated in the code then, and wiki changes needs to be made. If contributed plugins rely on it, it makes no difference since it is not being called (so their code will not be executed), if they do something like $this->config_save or parent::config_save somewhere, this will still work as deprecated function will handle it.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kabalin Ruslan Kabalin
              Reporter:
              kabalin Ruslan Kabalin
              Peer reviewer:
              Marina Glancy
              Integrator:
              David Monllaó
              Tester:
              Zachary Durber
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                11/May/15