Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-49574

?query_strings not recognised in custom menu items

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.7.3
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None
    • Affected Branches:
      MOODLE_27_STABLE

      Description

      Moodle 2.7.2
      Site admin > Appearance > Themes > Theme settings > custom menu items

      Having trouble adding a menu item that includes a query string.
      The target="_blank" attribute is working for all the URLs except the last one.
      The only difference seems to be the query string in the URL (id=7246).
      All URLs open in a new tab (Chrome) except for the last one, which opens in the same tab.

      -----------------------

      Moodle community

      -Home|https://moodle.org/" target=\"_blank|Moodle website for all things Moodle

      -Support forums|https://moodle.org/support\" target=\"_blank|Get help from Moodle users

      -Documentation|https://docs.moodle.org/27/en\" target=\"_blank|Teach yourself

      -How to Use Moodle 2.7|http://www.moodlenews.com/2014/free-book-how-to-use-moodle-2-7-360-pages-of-moodle/\" target=\"_blank|A free 360-page ebook on how to use Moodle 2.7

      -Moodle books|https://moodle.org/mod/data/view.php?id=7246\" target=\"_blank|Many books about Moodle

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              danmarsden Dan Marsden
              Reporter:
              markh46 Mark Hayes
              Participants:
              Component watchers:
              Bas Brands
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: