Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-49651

Hidden course sending forum messages

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Create a new course with visibility hidden
      2. Enrol one student, and one editing teacher in the course
      3. Create a new forum in the course
      4. Set the subscription type (via the module's settings cog) to forced subscription
      5. Make a forum post, making sure to tick the "Send forum post notifications with no editing-time delay " box.
      6. Run the Forum Cron Task:

        php admin/tool/task/cli/schedule_task.php --execute="\mod_forum\task\cron_task"
        

        1. Confirm that the student did not receive the message
        2. Confirm the cron output did not say that the student received the post
        3. Confirm that the teacher did receive the message
        4. Confirm the cron output did reported that the teacher did received the post
      Show
      Create a new course with visibility hidden Enrol one student, and one editing teacher in the course Create a new forum in the course Set the subscription type (via the module's settings cog) to forced subscription Make a forum post, making sure to tick the "Send forum post notifications with no editing-time delay " box. Run the Forum Cron Task: php admin/tool/task/cli/schedule_task.php --execute="\mod_forum\task\cron_task" Confirm that the student did not receive the message Confirm the cron output did not say that the student received the post Confirm that the teacher did receive the message Confirm the cron output did reported that the teacher did received the post
    • Affected Branches:
      MOODLE_27_STABLE, MOODLE_34_STABLE, MOODLE_35_STABLE, MOODLE_36_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE, MOODLE_34_STABLE, MOODLE_35_STABLE, MOODLE_36_STABLE
    • Pull 3.5 Branch:
    • Pull 3.6 Branch:
    • Pull Master Branch:
      MDL-49651-master

      Description

      We are currently using Moodle 2.7.1 Build 20140714.
      In a hidden Moodle course, messages posted to the News Forum are being sent to all users. This causes confusion because the users/students can't then see the message in context.
      I had assumed that if a course (or forum) was hidden, messages would not be sent to participants.
      A previous tracker ticket (MDL-5697) was posted a few years ago regarding a hidden forum sending messages.
      In our case, the entire course is hidden and lecturers who are new to Moodle, have been practising editing Moodle and therefore using the News Forum in a test capacity. They, and we, assumed messages would not be sent out.
      I'm not sure if this is a bug or a strange feature but perhaps someone could let me know or perhaps know a way of fixing it.
      Steps I took to re-create the problem:
      1) Navigate to a hidden course in Moodle
      2) Post a test message in the main News Forum
      3) Check to see if users with student roles received the message
      In this case, both student and teacher roles received the message I posted.

        Attachments

        1. image-2019-01-09-17-18-12-451.png
          105 kB
          Janelle Barcega
        2. MDL-49651-29.mdk.patch
          1.0 kB
          Andrew Nicols
        3. MDL-49651-30.mdk.patch
          1.0 kB
          Andrew Nicols
        4. MDL-49651-31.mdk.patch
          1.0 kB
          Andrew Nicols
        5. MDL-49651-master.mdk.patch
          1.0 kB
          Andrew Nicols

          Issue Links

            Activity

              People

              • Votes:
                9 Vote for this issue
                Watchers:
                16 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/Jan/19

                  Time Tracking

                  Estimated:
                  Original Estimate - 0 minutes
                  0m
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 hour
                  1h