Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-50277

uglify-js version needs to be sticky

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Fixed
    • 2.9, 3.0
    • 2.9.1
    • JavaScript

    Description

      It seems we need strict version requirements on uglify-js in order to produce a consistent build output.

      With the current package.json config I ended up with uglify-js version 2.4.17 - which produces output which matches git master.

      But Eloy npm-install'd and got 2.4.22 - which produces different output.

      I confirmed this mismatch by removing my old node_modules and getting 2.4.22

      Attachments

        Issue Links

          Activity

            People

              dobedobedoh Andrew Lyons
              poltawski Dan Poltawski
              Damyon Wiese Damyon Wiese
              Eloy Lafuente (stronk7) Eloy Lafuente (stronk7)
              Eloy Lafuente (stronk7) Eloy Lafuente (stronk7)
              Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Stevani Andolo
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                6/Jul/15