Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-50572

Youtube repository should be disabled by default.

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      Verify that Youtube repository is disabled.

      1. Install and configure a new Moodle instance.
      2. Login as an administrator
      3. Go to Site administration ► Plugins ► Repositories ► Manage repositories
      4. Check the "Active?" column for the row "Youtube videos"

      Expected Results:

      1. The "Active?" column for the row "Youtube videos" should be set as "Disabled"

      Verify that block_tag_youtube is disabled

      1. Install and configure a new Moodle instance.
      2. Login as an administrator
      3. Go to Site administration ► Plugins ► Blocks ► Manage blocks
      4. Check the "Youtube" row.

      Expected Results:

      1. The "Youtube" row should be greyed out with an icon in its "Hide/Show" column that indicates that it is currently hidden.
      Show
      Verify that Youtube repository is disabled. Install and configure a new Moodle instance. Login as an administrator Go to Site administration ► Plugins ► Repositories ► Manage repositories Check the "Active?" column for the row "Youtube videos" Expected Results: The "Active?" column for the row "Youtube videos" should be set as "Disabled" Verify that block_tag_youtube is disabled Install and configure a new Moodle instance. Login as an administrator Go to Site administration ► Plugins ► Blocks ► Manage blocks Check the "Youtube" row. Expected Results: The "Youtube" row should be greyed out with an icon in its "Hide/Show" column that indicates that it is currently hidden.
    • Affected Branches:
      MOODLE_29_STABLE, MOODLE_30_STABLE
    • Fixed Branches:
      MOODLE_30_STABLE
    • Pull Master Branch:
      MDL-50572-master
    • Sprint:
      Team '; drop tables Sprint 9

      Description

      With MDL-50176 going in, youtube repo need api key to work. If api key is not set it will not be shown in the file picker.

      It will be nice to disable it by default for new installs.

      The same with block_tag_youtube

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jpataleta Jun Pataleta
              Reporter:
              rajeshtaneja Rajesh Taneja
              Peer reviewer:
              Ryan Wyllie
              Integrator:
              Eloy Lafuente (stronk7)
              Tester:
              Adrian Greeve
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                16/Nov/15