Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-50770

Problem configuring where a blocks appears on "My Dashboard"

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Make sure you have some site-wide blocks, if you use Boost and there is no Navigation add some blocks and set "display throughout site"
      2. As admin go to /my/indexsys.php and change positions or visibility of these site-wide blocks
      3. As another user reset your dashboard and make sure it looks exactly like the default one
      4. Repeat with /user/profilesys.php and resetting user profile page

      Test for the situation described in MDL-55817 :

      1. As admin on the default dashboard edit some block configuration and change default region and/or weight, so that default region (or weight) is no longer the same as region (or weight) on this page. Do this with the blocks that exist on dashboard only, for example, course overview or private files
      2. As another user reset your dashboard and make sure it looks exactly like the default one. If you open configuration of the same block you should see the same values ("default" and "on this page" should be different).
      Show
      Make sure you have some site-wide blocks, if you use Boost and there is no Navigation add some blocks and set "display throughout site" As admin go to /my/indexsys.php and change positions or visibility of these site-wide blocks As another user reset your dashboard and make sure it looks exactly like the default one Repeat with /user/profilesys.php and resetting user profile page Test for the situation described in MDL-55817 : As admin on the default dashboard edit some block configuration and change default region and/or weight, so that default region (or weight) is no longer the same as region (or weight) on this page. Do this with the blocks that exist on dashboard only, for example, course overview or private files As another user reset your dashboard and make sure it looks exactly like the default one. If you open configuration of the same block you should see the same values ("default" and "on this page" should be different).
    • Affected Branches:
      MOODLE_29_STABLE, MOODLE_31_STABLE, MOODLE_32_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE, MOODLE_32_STABLE
    • Pull Master Branch:
      wip-MDL-50770-master
    • Sprint:
      3.3 sprint 2

      Description

      When I set positions of the navigation block on default dashboard page it does not replicate to users dashboard page. Also, if I edit Navigation block, click to edit the block and set the region "on this page" to something different, it does not set the region to all users. Other blocks works fine, this issue only happens with some blocks for instance navigation block.

      1. Configure "defaulthomepage = Dashboard"
      2. Go to Appearence -> Default Dashboard Page
      3. Click blocks edition on
      4. Drag and drop navigation block in a different region
      5. Reset the dashboard for all users.
      6. Log in as a different user, and see the navigation block position hasn't changed.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              marina Marina Glancy
              Reporter:
              dacapri David Cabrera Primo
              Peer reviewer:
              Simey Lameze
              Integrator:
              David Monllaó
              Tester:
              Ankit Agarwal
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona)
              Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                13/Mar/17