Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-50925

Moving some auth plugins to plugins repo

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 3.4
    • Component/s: Authentication
    • Labels:
    • Testing Instructions:
      Hide
      1. Perform upgrade
        1. Confirm that old plugins are no longer present
      2. *Check for any other references to them

      The following plugins have been removed:

      1. auth_imap
      2. auth_fc
      3. auth_pop
      4. auth_nntp
      5. auth_pam
      Show
      Perform upgrade Confirm that old plugins are no longer present *Check for any other references to them The following plugins have been removed: auth_imap auth_fc auth_pop auth_nntp auth_pam
    • Affected Branches:
      MOODLE_30_STABLE
    • Fixed Branches:
      MOODLE_34_STABLE
    • Pull Master Branch:
      MDL-50925-master

      Description

      See https://moodle.org/mod/forum/discuss.php?d=317353 for the discussion on this.

      I feel that we should move the following plugins to the plugin repo with, or without a maintainer:

      1. auth_fc (FirstClass)
        1. lack of testing resource availability at HQ
        2. I imagine that few people still use FC any longer
      2. auth_nntp (Network News Transfer Protocol)
        1. Probably rarely used these days
        2. We don't test at HQ (though we technically can)
      3. auth_pop3 (POP3 Mail server)
        1. Probably rarely used these days
        2. We don't test at HQ (though we technically can)
      4. auth_imap (IMAP Mail server)
        1. Probably rarely used these days
        2. We don't test at HQ (though we technically can)
      5. auth_pam
        1. Probably rarely used these days
        2. We don't test at HQ (though we technically can)
        3. Requires a PECL module be installed. Without the module installed in it's current state if the plugin is enabled, this causes WSOD + 500 issues when an unknown user tries to login. We aren't able to add this to our environment checklist because it will require for all of Moodle unnecessarily.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                2 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  13/Nov/17