Moodle
  1. Moodle
  2. MDL-5131

RSS Feeds and Moving Discussions

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: None
    • Component/s: Forum
    • Labels:
      None
    • Environment:
      All
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Rank:
      11353

      Description

      RSS feeds generated from the Forum module to do not reflect changes when a discussion is moved from one forum to another

      Steps to recreate the problem on Moodle 1.6 beta 2

      1. Create 2 forums called Sample 1 and Sample 2

      2. Start a few discussions in each forum.

      3. Call admin/cron.php to build / update the RSS feeds

      4. Move one discussion from Sample 1 to Sample 2

      5. Call admin/cron.php to rebuild the RSS feeds

      The discussion you moved from forum Sample 1 to Sample 2 will still appear in the RSS feed from Sample 1 and will not appear in forum Sample 2.

      The link to the discussion in the RSS feed from Sample 1 will bring you to the discussion now residing in forum Sample 2

      Environment:

      Windows Server 2003

      PHP 5.0.5

      MySQL 4.1.16

        Activity

        Martin Dougiamas added a comment -

        From (scott.elliott at mchsi.com) Saturday, 8 April 2006, 09:06 AM:

        I think what happens is as follows:

        http://moodle.cvs.sourceforge.net/moodle/moodle/mod/forum/rsslib.php checks for new posts/discussions based on the posts created date.

        When a discussion is moved, the new location has a create date since the last rss feed generation, so it generates the new rss feed.

        The old discussion has the same old create date, so no new rss feed.

        Should forum_rss_feed_posts() and forum_rss_feed_discussions() use the modified date instead of the create date?

        From (scott.elliott at mchsi.com) Sunday, 9 April 2006, 09:57 PM:

        Splitcamera Spammer strikes again! Is their anyway of finding out who this is and stopping them?

        I've seen two instances of them changing the summary and URL.

        From Stephen Bourget (sbourget at goffstown.k12.nh.us) Tuesday, 11 April 2006, 06:07 AM:

        That makes sense to me...

        One note however, neither RSS feed updates.

        The discussion moved to from forum Sample 1 to forum Sample 2 will remain in the RSS feed from Sample 1 and not appear in forum Sample 2

        From Martin Dougiamas (martin at moodle.com) Friday, 21 April 2006, 12:42 PM:

        Vy, can you make sure both feeds are regenerated after a discussion is moved from one forum to another (only if RSS feeds are active of course)?

        Also, all of us should be aware that news syndicators can cache older entries so that deleting something from the feed will not necessarily delete it from a syndicator. Google's personal page still shows some test entries I deleted from a Database activity weeks ago.

        From Stephen Bourget (sbourget at goffstown.k12.nh.us) Thursday, 1 June 2006, 04:09 AM:

        Looking at the construction of the forum module the move discussion option seems to only change the forum field in the table mdl_forum_discussions. It doesn't seem to change the date so the RSS feeds Don't know the discussion has changed.

        Should the code that moves the discussion in http://moodle.cvs.sourceforge.net/moodle/moodle/mod/forum/discuss.php also change the modified field in the table mdl_forum_posts to allow the RSS feed to rebuild?

        From Vy-Shane Sin Fat (vy-shane at moodle.com) Wednesday, 7 June 2006, 04:20 PM:

        Fixed in 1.6 and 1.7.

        Michael Blake added a comment -

        assign to a valid user

        Martín Langhoff added a comment -

        This suffered a regression on HEAD I have just fixed.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: