Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-51580

Decide Moodle 3.1 requirements and push them to environment.xml (due date: 30/11/2015)

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      A) Standard testing:
      0) To test exclusively in all supported stable branches.
      1) Go to admin -> server -> environment
      2) One "3.1 upwards" Moodle version should be available.
      3) It shows the same requirements than a 3.0 version but with these differences:
      3.1) The first check shows that Moodle 2.7 is required for installing 3.1.

      B) This release testing (requires database access):
      1) Install Moodle 2.6.x+ (or older).
      2) Upgrade codebase to master.
      3) Start upgrade, both via web and cli, environment page/report must prevent upgrade to happen, detecting that 2.7 is required.
      4) Edit your database and set change the "release" record in "config" table from "2.x.y..." (whatever you installed in step #1) to "2.7.y..."
      5) Start upgrade again, also via web and cli, environment page/report now passes (because you've hacked the site badly) but, still, the process stops with message "You need to upgrade to 2.7.x or higher first!" under the core/system component.

      C) Run unit tests (mysql and mssql at very least).

      D) Install a 2.7.0 site with some real content (complex courses, users, repositories, availability...) and upgrade it to 3.1, also both via web and cli. Process should finish without problem.

      Show
      A) Standard testing: 0) To test exclusively in all supported stable branches. 1) Go to admin -> server -> environment 2) One "3.1 upwards" Moodle version should be available. 3) It shows the same requirements than a 3.0 version but with these differences: 3.1) The first check shows that Moodle 2.7 is required for installing 3.1. B) This release testing (requires database access): 1) Install Moodle 2.6.x+ (or older). 2) Upgrade codebase to master. 3) Start upgrade, both via web and cli, environment page/report must prevent upgrade to happen, detecting that 2.7 is required. 4) Edit your database and set change the "release" record in "config" table from "2.x.y..." (whatever you installed in step #1) to "2.7.y..." 5) Start upgrade again, also via web and cli, environment page/report now passes (because you've hacked the site badly) but, still, the process stops with message "You need to upgrade to 2.7.x or higher first!" under the core/system component. C) Run unit tests (mysql and mssql at very least). D) Install a 2.7.0 site with some real content (complex courses, users, repositories, availability...) and upgrade it to 3.1, also both via web and cli. Process should finish without problem.
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_31_STABLE
    • Fixed Branches:
      MOODLE_27_STABLE, MOODLE_28_STABLE, MOODLE_29_STABLE, MOODLE_30_STABLE
    • Pull Master Branch:
    • Story Points:
      13
    • Sprint:
      BACKEND Sprint 8

      Description

      We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

      At the same time, if there is any change in the PHP version... some changes have to be populated to various installers and replace them by the new one when corresponding. To get a list of candidates:

      grep -r '5\.x\.y' * | grep '\.php'

      (and look for MDL-39007 status, about to unify all those duplicated checks)

      Ciao

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                19 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/Mar/16