Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-51758

Remove password_compat library

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0, 3.1
    • Fix Version/s: 3.2
    • Component/s: Libraries
    • Labels:
    • Testing Instructions:
      Hide
      1. git grep for password_compat - there should be no code uses
      2. create a test php file in your doc root with contents:

        <?php
        require_once('config.php');
        require_once($CFG->libdir . '/password_compat/lib/password.php');
        

      3. View it in your browser
        1. Confirm that you get a debugging notice regarding deprecation
      Show
      git grep for password_compat - there should be no code uses create a test php file in your doc root with contents: <?php require_once('config.php'); require_once($CFG->libdir . '/password_compat/lib/password.php'); View it in your browser Confirm that you get a debugging notice regarding deprecation
    • Affected Branches:
      MOODLE_30_STABLE, MOODLE_31_STABLE
    • Fixed Branches:
      MOODLE_32_STABLE
    • Pull Master Branch:
      MDL-51758-master
    • Story Points:
      1
    • Sprint:
      3.2 Sprint 3

      Description

      Once we have increased our minimum version to PHP 5.5.0, we can drop use of this library in Moodle.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/Dec/16