Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-51990

If Moodle needs upgrading anyone can access the /admin/index.php

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.9.1
    • Fix Version/s: 3.0
    • Component/s: Administration
    • Labels:
      None
    • Affected Branches:
      MOODLE_29_STABLE
    • Fixed Branches:
      MOODLE_30_STABLE

      Description

      If moodle_needs_upgrading() is true anyone (logged or not) can access the admin index site, view details of installed plugins and download new plugin versions.

      1. Downgrade or upgrade a pluging version
      2. Go to /admin/index.php when not logged it or logged in as a non-admin user
      3. Use automatic installation for a plugin

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            jkb Jakub Kania
            Participants:
            Component watchers:
            Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              16/Nov/15