Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-52039

Hard-coded English language strings in block_tags

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.7.10, 2.8.8, 2.9.2, 3.0
    • Fix Version/s: 2.9.4
    • Component/s: Blocks, Tags
    • Labels:
    • Testing Instructions:
      Hide

      Moodle 3.0:

      1. Add tags block and make sure it has no setting "Tags to display" and the block is displayed properly

      Moodle 2.9

      1. Add tags block and make sure it has no setting "Tags to display" and the block is displayed properly
      2. Go to block_tags plugin settings and enable show course tags
      3. Go to the settings of block instance and make sure the setting "Tags to display" is present.
        P.S. Even when present it works very weirdly so I don't include it in testing instructions
      Show
      Moodle 3.0: Add tags block and make sure it has no setting "Tags to display" and the block is displayed properly Moodle 2.9 Add tags block and make sure it has no setting "Tags to display" and the block is displayed properly Go to block_tags plugin settings and enable show course tags Go to the settings of block instance and make sure the setting "Tags to display" is present. P.S. Even when present it works very weirdly so I don't include it in testing instructions
    • Affected Branches:
      MOODLE_27_STABLE, MOODLE_28_STABLE, MOODLE_29_STABLE, MOODLE_30_STABLE
    • Fixed Branches:
      MOODLE_29_STABLE
    • Pull Master Branch:
      wip-MDL-52039-master

      Description

      I was testing 3.0 DEV Moodle 3.0beta+ (Build: 20151031) in a new local Windows server

      Added a 100% translated language pack (es_mx). Choose this language.

      Added a new course

      Added a tags block

      Edited tag block settings

      Choose 'Number of tags to display' dropdown menu

      The three choices shown (default, official, both) are hard-coded English strings and not available for translation in AMOS.

      This was posted in AMOS forum thread https://lang.moodle.org/mod/forum/discuss.php?d=4726#p5561 and confirmed by David Mudrak. It seems to affect all Moodle branches from 2.4 to DEV.

      Please add David Mudrak as watcher.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jan/16