Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-52365

Quiz: Browsers (IE11 and edge) become slow/unresponsive for quizzes which contain D&D with 20 drag items.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0, 3.1
    • Fix Version/s: 3.0.2
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      Hide

      How to reproduce before applying the patch

      1. Create a quiz with several questions
      2. At least have a ddimageortext qtpe with 20 or more drag items whcih are set to infinte and all drag items belong to the same group
      3. At least have a ddwtos qtpe with 20 or more drag items whcih are set to infinte and all drag items belong to the same group (you may have a 4X5 table
      4. Attempt the quiz, finish and submit all
      5. At the quiz review page when all question are shown on one page, this can be very slow and then become unresponsive in IE11
      Show
      How to reproduce before applying the patch Create a quiz with several questions At least have a ddimageortext qtpe with 20 or more drag items whcih are set to infinte and all drag items belong to the same group At least have a ddwtos qtpe with 20 or more drag items whcih are set to infinte and all drag items belong to the same group (you may have a 4X5 table Attempt the quiz, finish and submit all At the quiz review page when all question are shown on one page, this can be very slow and then become unresponsive in IE11
    • Affected Branches:
      MOODLE_30_STABLE, MOODLE_31_STABLE
    • Fixed Branches:
      MOODLE_30_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-52365_new
    • Sprint:
      CBE Sprint 2

      Description

      When you have a quiz with few dd qtypes and if one or two of the questions (ddwtos and ddimageortext) have about 20 drag items it become very slow when attempting a dd question with 20 darg item and unresponsive when reviewing all question on one page. It seems to be fine on Chrome and Firefox, but this happens on IE11 and Edge (OU bug #103431)

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jan/16