Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-52585

login/token.php returns an incorrect message when the user enter invalid credentials

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. As admin, enable "Mobile services": Plugins ► Web Services ► Mobile
      2. Now, execute the following CURL call pointing to your installation (you should use and invalid user or password)

        curl 'http://localhost/m/stable_master/login/token.php' --data 'username=student&password=abc&service=moodle_mobile_app' --compressed

      3. Confirm that the response is a json string containing the error: Invalid login, please try again
      Show
      As admin, enable "Mobile services": Plugins ► Web Services ► Mobile Now, execute the following CURL call pointing to your installation (you should use and invalid user or password) curl 'http://localhost/m/stable_master/login/token.php' --data 'username=student&password=abc&service=moodle_mobile_app' --compressed Confirm that the response is a json string containing the error: Invalid login, please try again
    • Affected Branches:
      MOODLE_30_STABLE
    • Fixed Branches:
      MOODLE_29_STABLE, MOODLE_30_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-52585-master

      Description

      This was reported by gavin henrick, in the Mobile app if you enter invalid credentials the login/token.php returns a "usernamenotfound" message when it should be "invalidlogin" as login/index.php does

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/Mar/16