Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-52685

doctrine/cache 1.6.x requires PHP 5.5, breaks composer on Moodle 2.9/PHP 5.4

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. run following on php 5.4.4

        php composer.phar install
        

      2. Check composer.lock and ensure there is no requirement of php above 5.4.4
      Show
      run following on php 5.4.4 php composer.phar install Check composer.lock and ensure there is no requirement of php above 5.4.4
    • Affected Branches:
      MOODLE_29_STABLE
    • Fixed Branches:
      MOODLE_29_STABLE

      Description

      MDL-51881 bumped versions for the moodle-behat-extension. guzzlehttp/guzzle sets most recent doctrine/cache as a dependency but doctrine/cache dropped support for PHP 5.4 in 1.6+. This has the effect of breaking composer installation for that environment (see e.g. https://travis-ci.org/LafColITS/moodle-report_roster/jobs/100417939, travis jobs for plugins which previously passed now fail). Forcing doctrine/cache at 1.5.* might work.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jan/16