Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-53019

Decide Moodle 3.2 requirements and push them to environment.xml (due date: 13/06/2016)

    XMLWordPrintable

Details

    • MOODLE_31_STABLE
    • MOODLE_27_STABLE, MOODLE_29_STABLE, MOODLE_30_STABLE, MOODLE_31_STABLE
    • Moderate
    • Hide

      0) To test exclusively in all supported stable branches.
      1) Go to admin -> server -> environment
      2) One "3.2 upwards" Moodle version should be available.
      3) It shows the same requirements than a 3.1 version but with these differences:

      a) PHP 5.6.5 is required

      On master only, with a site installed, try the following:

      i) Downgrade PHP to anything < PHP 5.6.5, let's call it, YOURVERSION.
      ii) The execution of *all the following (A-E steps below) should lead to the output of the message* "Moodle 3.2 or later requires at least PHP 5.6.5 (currently using version YOURVERSION)". Some more text can be output, but it's not important for this issue testing.

      A) Web install: Rename your config.php to config.php.saved. Go to your site/install.php.
      B) Admin page: Rename the config.php.saved back to config.php. Go to your site/admin.php
      C) CLI install: Run php admin/cli/install.php
      D) Database install: Run php admin/cli/install_database.php
      E) Any CLI script: Run php admin/cli/fix_deleted_users.php or any other CLI script.

      Show
      0) To test exclusively in all supported stable branches. 1) Go to admin -> server -> environment 2) One "3.2 upwards" Moodle version should be available. 3) It shows the same requirements than a 3.1 version but with these differences: a) PHP 5.6.5 is required On master only, with a site installed, try the following: i) Downgrade PHP to anything < PHP 5.6.5, let's call it, YOURVERSION. ii) The execution of * all the following (A-E steps below) should lead to the output of the message * "Moodle 3.2 or later requires at least PHP 5.6.5 (currently using version YOURVERSION)". Some more text can be output, but it's not important for this issue testing. A) Web install: Rename your config.php to config.php.saved. Go to your site/install.php. B) Admin page: Rename the config.php.saved back to config.php. Go to your site/admin.php C) CLI install: Run php admin/cli/install.php D) Database install: Run php admin/cli/install_database.php E) Any CLI script: Run php admin/cli/fix_deleted_users.php or any other CLI script.
    • 13
    • BACKEND Sprint 8

    Description

      We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

      All the still open linked issues have been cloned here from the 3.1 sister issue (MDL-51580).

      Usual discussions:

      • PHP min. version.
      • database versions.
      • Linked issues.
      • ...

      Feel free to propose areas to be discussed here. A numbered list with all them will be created to vote and decide the final outcomes of this issue.

      TIA and ciao

      Attachments

        Issue Links

          Activity

            People

              stronk7 Eloy Lafuente (stronk7)
              stronk7 Eloy Lafuente (stronk7)
              Dan Poltawski Dan Poltawski
              Andrew Lyons Andrew Lyons
              Jun Pataleta Jun Pataleta
              Matteo Scaramuccia, David Woloszyn, Huong Nguyen, Jake Dallimore, Michael Hawkins, Stevani Andolo, Huong Nguyen, Bas Brands, Mathew May
              Votes:
              0 Vote for this issue
              Watchers:
              20 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                11/Jul/16