Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-53544

Investigate a replacement for Typo3 library

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 3.2, 3.8
    • Fix Version/s: None
    • Component/s: Libraries
    • Labels:
    • Affected Branches:
      MOODLE_32_STABLE, MOODLE_38_STABLE
    • Epic Link:

      Description

      At the moment we use Typo3 version 4.7.19 on core, mostly for charset and encoding stuff, see lib/classes/text.php.

      However that version is out of support and would be expensive move our code to use the latest version. The Typo jumped from 4.7.20 version to 6.X version and there were lots of structural changes and lots of legacy code of the 4.X version that got refactored.

      The goal of this issue is to verify the possibility of replace our Typo3 library by PHP iconv functions.

      A bit of history about this Typo 4.7 to 6.0 version jump: https://typo3.org/news/article/from-47-to-60-a-brief-history-of-typo3-versioning/

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                4 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated: