Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-53596

Make CLI upgrade to verify upgrade_stale_php_files_present()

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 2.9.5, 3.0.3, 3.1, 3.2
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Affected Branches:
      MOODLE_29_STABLE, MOODLE_30_STABLE, MOODLE_31_STABLE, MOODLE_32_STABLE

      Description

      Right now it seems that only the web installed checks upgrade_stale_php_files_present() preventing upgrade to proceed. CLI version ignores it completely.

      Unless I'm missing something, I think the CLI version should be performing the check and reporting the problem in the same way the web one does it.

      Ciao

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              stronk7 Eloy Lafuente (stronk7)
              Participants:
              Component watchers:
              Matteo Scaramuccia, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              2 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated: