Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-53687

Webm video is displayed as black box in Edge

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Create a new page
      2. In the content, use the 'Insert Moodle Media' option in the editor to upload media files:
        • Webm videos
        • OGG audio
      3. Save the page
      4. View page in Edge
        • Confirm that the medias are displayed as links
      5. View page in Chrome, or Firefox
        • Confirm that the medias are displayed as a player
      Show
      Create a new page In the content, use the 'Insert Moodle Media' option in the editor to upload media files: Webm videos OGG audio Save the page View page in Edge Confirm that the medias are displayed as links View page in Chrome, or Firefox Confirm that the medias are displayed as a player
    • Affected Branches:
      MOODLE_30_STABLE
    • Fixed Branches:
      MOODLE_30_STABLE, MOODLE_31_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-53687-master
    • Sprint:
      3.2 Sprint 1

      Description

      When adding a video via the Moodle Media option to a Wiki in Internet Explorer(version 11.162.10586.0) and Edge (25.10586.0.0) the video will not embed and does not display in the Moodle media player.

      Steps to replicate

      1. Create a Wiki on a 3.0.3 site
      2. Create a wiki page in HTML format
      3. Use the 'Insert Moodle Media' option in the editor to upload the video file (Im using a webm video)
      4. Insert the video
      5. Save the Wiki page
      6. View page in Internet Explorer
      7. View page in Chrome
      8. View page in Edge

      The expected result is for the video to display in the player, however the actual result in the case of Internet explorer is the videos display as a link that when clicked prompts a download of the video. In the case of Edge the videos display in a non interactive black window with the text 'Invalid source'. The video displays correctly in Chrome.

        Attachments

        1. Chrome_wiki.JPG
          Chrome_wiki.JPG
          36 kB
        2. Edge_wiki.JPG
          Edge_wiki.JPG
          29 kB
        3. IE_wiki.JPG
          IE_wiki.JPG
          25 kB

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                11/Jul/16