Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-53717

Notice: Trying to get property of non-object while installing site.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1
    • Component/s: Messages
    • Labels:
    • Testing Instructions:
      Hide
      1. Create a temporary site.
      2. Add the following to your config.php file.

        @error_reporting(E_ALL | E_STRICT); // NOT FOR PRODUCTION SERVERS!
        @ini_set('display_errors', '1'); // NOT FOR PRODUCTION SERVERS!
        $CFG->debug = (E_ALL | E_STRICT); // === DEBUG_DEVELOPER - NOT FOR PRODUCTION SERVERS!
        $CFG->debugdisplay = 1; // NOT FOR PRODUCTION SERVERS!

      3. Delete all the tables in your database so that Moodle goes through the installation process.
      4. Ensure the following PHP notice does not display -

        Notice: Trying to get property of non-object in /home/markn/mstorage/tmp/moodle/lib/outputrenderers.php on line 1065
        

      Show
      Create a temporary site. Add the following to your config.php file. @error_reporting(E_ALL | E_STRICT); // NOT FOR PRODUCTION SERVERS! @ini_set('display_errors', '1'); // NOT FOR PRODUCTION SERVERS! $CFG->debug = (E_ALL | E_STRICT); // === DEBUG_DEVELOPER - NOT FOR PRODUCTION SERVERS! $CFG->debugdisplay = 1; // NOT FOR PRODUCTION SERVERS! Delete all the tables in your database so that Moodle goes through the installation process. Ensure the following PHP notice does not display - Notice: Trying to get property of non-object in /home/markn/mstorage/tmp/moodle/lib/outputrenderers.php on line 1065
    • Affected Branches:
      MOODLE_31_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-53717_master

      Description

      I am seeing following notice while installing a site via web.

      Notice: Trying to get property of non-object in /home/rajesh/moodles/im/moodle/lib/outputrenderers.php on line 1065 ???
      

      Reason being context is null at the time of installation.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  23/May/16