Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 1.6
    • Fix Version/s: None
    • Component/s: Blog
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_16_STABLE
    • Rank:
      11431

      Description

      Is it possible to access logs for blogs?

      It doesn't seem to be in any of the logs dropdowns (activity or course/site is where I was expecting it) nor in the blogs pages/blocks.

      Discussion started at: http://moodle.org/mod/forum/discuss.php?d=44503

        Activity

        Darren Smith created issue -
        Martin Dougiamas added a comment -

        From Yu Zhang (yu at moodle.com) Monday, 1 May 2006, 02:27 PM:

        Hi Darren,

        At site level, I could see user's blogging activities showing up in the logs. Blog is not really course related, I think.

        Yu

        From Darren Smith (dagza72 at gmail.com) Monday, 1 May 2006, 05:24 PM:

        Thanks for the response.

        I agree blogs aren't course level and I can also see blogging activity in the logs but what I perhaps should have said is I can't filter it.

        I can filter site, courses, people, dates and and so on but I would have expected blogs to have appeared in the activities drop down box for the site.

        From Darren Smith (dagza72 at gmail.com) Monday, 1 May 2006, 05:31 PM:

        On that note I had a quick check and it would appear viewing blog entries is not logged on my site - only edits.

        Michael Blake made changes -
        Field Original Value New Value
        Assignee Yu Zhang [ yuzhang ] Yu Zhang [ lazyfish ]
        Charles Kelly added a comment -

        Re: blogs aren't course level

        As a foreign language teacher, I would love to see user's blogging activities showing up in their logs.

        Our teachers have students write blogs and read each others blogs as part of the assigned work for their English as a second language courses.

        Yu Zhang added a comment -

        Hi,

        Both viewing and blogging are already logged, but at the site level. Technically there's no way to associate a blogging action with a course because the user can just log in, lick on himself and blog, without going through any courses. Blogs are not associated with courses. I am not sure this is possible.

        Cheers,

        Yu

        Nicla Rossini added a comment -

        Hi, I seem to have a similar problem with moodle: I should be supposed to post blogs, being a teacher, but I only can see these links on my profile page: 1)view my entries 2)blog preferences 3)view course entries 4) view site entries.
        The link "Add new entry" is supposed to be there, but there's no trace of it.

        What can I do to solve this?

        Thanks,
        Nicla

        Eloy Lafuente (stronk7) added a comment -

        Hi Charles, Nicla. This is pretty old and I'm going to close this as won't fix.

        About the possibility to add blog logs per course, then as Yu commented, it's necessary to assign blogs to courses and that's right now, impossible. Anyway, this yeat GSOC of code will include, surely, one project related with blogs improvements. I'd suggest to comment about that there ( http://moodle.org/mod/forum/view.php?id=7105 ) or perhaps revive it in the Blogs forum ( http://moodle.org/mod/forum/view.php?id=2471 ).

        Nicla, about your issue, I'd suggest you to open a new bug in the tracker, commenting the steps needed to reproduce the problem, the version of Moodle affected and the expected behaviour. That way, the bug can be assigned to one developer.

        Thanks and ciao

        Eloy Lafuente (stronk7) made changes -
        Status In Progress [ 3 ] Closed [ 6 ]
        Resolution Won't Fix [ 2 ]
        Assignee Yu Zhang [ lazyfish ] Mathieu Petit-Clair [ scyrma ]
        Martin Dougiamas made changes -
        Workflow jira [ 16064 ] MDL Workflow [ 52396 ]
        Martin Dougiamas made changes -
        Workflow MDL Workflow [ 52396 ] MDL Full Workflow [ 81509 ]

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: