Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-53879

Invalid persistent error dialogue being displayed when relocating a competency to the lowest level competency

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1
    • Component/s: Competencies
    • Labels:
    • Testing Instructions:
      Hide

      Test 1

      1. Create a new framework
      2. Set the taxonomy fields to other terms than 'Competency'.
      3. Make sure you only saw 4 taxonomy fields upon creation
      4. Edit the framework, make sure you see 4 taxonomy fields with the right values
      5. Add competencies to the framework to reach a depth > 4
      6. Make sure that the competencies at depth > 4 use the term 'Competency'.
      7. Make sure you see n taxonomy fields when editing the framework. N is the depth of your framework.
      8. Make sure that customising the additional taxonomy fields work (depth > 4 use the new terms)

      Test 2

      1. When creating competencies, make sure that you can set another parent from the form itself.
        • Also check that you can set the new parent at any depth
      2. Confirm that you can relocate competencies to any depth
      3. Confirm that you can add competencies to any depth (+ competency button is visible)
      Show
      Test 1 Create a new framework Set the taxonomy fields to other terms than 'Competency'. Make sure you only saw 4 taxonomy fields upon creation Edit the framework, make sure you see 4 taxonomy fields with the right values Add competencies to the framework to reach a depth > 4 Make sure that the competencies at depth > 4 use the term 'Competency'. Make sure you see n taxonomy fields when editing the framework. N is the depth of your framework. Make sure that customising the additional taxonomy fields work (depth > 4 use the new terms) Test 2 When creating competencies, make sure that you can set another parent from the form itself. Also check that you can set the new parent at any depth Confirm that you can relocate competencies to any depth Confirm that you can add competencies to any depth (+ competency button is visible)
    • Affected Branches:
      MOODLE_31_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-53879-master

      Description

      When relocating a competency to a bottom-level competency an "Invalid persistent" error dialogue comes up.

      We should prevent the user from being able to drag/relocate a competency under a bottom-level competency, or at least replace this error message with a proper one.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              fred Frédéric Massart
              Reporter:
              jpataleta Jun Pataleta
              Peer reviewer:
              Jun Pataleta
              Integrator:
              Dan Poltawski
              Tester:
              Mark Nelson
              Participants:
              Component watchers:
              Damyon Wiese, Jean-Philippe Gaudreau, Steve Massicotte, Serge Gauthier, Issam Taboubi, Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                23/May/16