Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-53923

unoconv should check for minimum version

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      Hide
      PRE-REQUISITES
      • To start the test, you MUST install unoconv version 0.6.
      TEST
      1. Visit Site administration ► Server ► Environment
      2. You should see the following warning message under Other checks:
        • The installed version of your unoconv is not supported, the required version for the assignment grading is 0.7
      3. Visit Site administration ► Plugins ► Activity modules ► Assignment ► Feedback plugins ► Annotate PDF
      4. Click on Test unoconv path link under Path to unoconv document converter
      5. You should see an warning saying the unoconv version is not supported.
      6. Now, install the unoconv version 0.7 or higher
        • Confirm the version by executing: unconv --version
      7. Site administration ► Server ► Environment
      8. You should NOT see any unoconv related warning.
      9. Visit Site administration ► Plugins ► Activity modules ► Assignment ► Feedback plugins ► Annotate PDF
      10. Click on Test unoconv path link under Path to unoconv document converter
      11. On the unoconv test page, you should see confirmation the unoconv path appears to be properly configured...
      12. Click on the Download button and make sure a test pdf was generated.
      Show
      PRE-REQUISITES To start the test, you MUST install unoconv version 0.6. TEST Visit Site administration ► Server ► Environment You should see the following warning message under Other checks : The installed version of your unoconv is not supported, the required version for the assignment grading is 0.7 Visit Site administration ► Plugins ► Activity modules ► Assignment ► Feedback plugins ► Annotate PDF Click on Test unoconv path link under Path to unoconv document converter You should see an warning saying the unoconv version is not supported. Now, install the unoconv version 0.7 or higher Confirm the version by executing: unconv --version Site administration ► Server ► Environment You should NOT see any unoconv related warning. Visit Site administration ► Plugins ► Activity modules ► Assignment ► Feedback plugins ► Annotate PDF Click on Test unoconv path link under Path to unoconv document converter On the unoconv test page, you should see confirmation the unoconv path appears to be properly configured... Click on the Download button and make sure a test pdf was generated.
    • Affected Branches:
      MOODLE_31_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      wip-MDL-53923-master

      Description

      Unoconv 0.7 is required for document conversions because it fixes some problems with running headless as apache user. 0.6 is the default on ubuntu lts - a few people have installed this older version and not checked. We should check and warn if their version is too old.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  23/May/16