Moodle
  1. Moodle
  2. MDL-5405

Lesson settings say questions, means pages - both counts are wrong

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: 1.6.2
    • Component/s: Lesson
    • Labels:
      None
    • Environment:
      Windows XP
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE
    • Rank:
      28185

      Description

      Think is this goes back to 1.5.3.

      Lesson Settings, Flow Control says

      Minimum number of questions: I put 4 .

      On page 7 (5 branch pages & 3 questions into a 13 page lesson) the screen told the student:

      Number of pages viewed: 8; (You should view at least: 4).

      Issue 1: The easy fix is to change Flow Control to read Minimum number of pages viewed. Don't know what others think about this.

      Issue 2: As a student (as the teacher with student view turned on, I used the browser back arrow button to try and trick the score. Moodle counted it as another attempt. However, it gave me credit for a page I did not view.

      I am running a course check to see how flow control and access control settings work between lessons.

        Activity

        Martin Dougiamas added a comment -

        From Chris (chris.collman at granite.edu) Wednesday, 3 May 2006, 08:37 AM:

        Browser BackPage button causing count errors

        Just lost my comments

        ran the attached course. Focused upon B lesson. When I discovered I answered the question wrong (standard Moodle response tells me, I used the backPage button to revisit the question. Flow control set at 2 attempts 4 pages visited.

        Here are my keystrokes for each of the 6 questions # 1,2,3,4,5,6 :

        Test 1, B lesson: c,c,c,c,c,c,c End told me 6 of 4 pages visited, 6 correct, score 6 of 6.

        Test 2, B lesson: wbc,c,c,c,c,c End told me 7 of 4 pages visited 6 correct, score 5.1 of 6.

        Test 3, B lesson: wbc, wbc,wbwbc, c,c,c End told me 10 or 4 pages visited, 6 correct, score 3.6 of 6.

        In test 3 I should not have scored 6 because max attempts was set at 2.

        Test 2 and 3 indicate the backpage button impacts scores.

        I did notice the screen on test 3, question 3 told me I had used up my attempts.

        Hi Ho Silver !

        From Mark Nielsen (man15 at humboldt.edu) Friday, 19 May 2006, 01:25 AM:

        Oh, this doesn't bode well at all. I have actually never used this setting and I was surprised by its help file. Currently, Lesson does not implement the correct grading scheme for custom scoring. Actually, how could we do this for custom scoring? It says that the student must answer X questions, and then their grade is calculated out of X. But with custom scoring, we don't know the point values of the questions that s/he could have answered... Going to have to think about this...

        I was able to reproduce your problems:

        Number of pages viewed is actually the count of the number of questions answered, so all stored attempts. This doesn't make since to me. It should behave more like this: I had 3 attempts on question 1 and 2 attempts on question 2, Number of pages viewed: 2 (instead of 5). Also, shouldn't it read, Number of questions answered?

        And then it looks as if the scoring is all wrong with custom scoring Off. It does not take into account the Maximum number of attempts setting (as reported by Chris).

        Chris brings up the issue with the o'l back button and re-answering the question. It seems that lesson should check if the student has reached his/her limit for the Maximum number of attempts and then if yes, report this instead of displaying the response.

        Proposed solutions:

        1. Change text from Number of pages viewed: Y; (You should view at least: X) to Number of questions answered: Y; (You should answer at least: X)

        2. Change the count method from number of total attempts to counting just number of questions answered.

        3. With custom scoring Off, make the grading algorithm respect the Maximum number of attempts setting.

        4. When processing a student's answer, check first to see if s/he has reached maximum number of attempts. If yes, then save answer with the flags field set (so far, this field has never been used, might as well use it for answers that don't count? Could also use it for late answers for timed lesson?).

        5. If custom scoring is On, how can one enforce this setting? Only solution that comes to mind is to ignore this setting with custom scoring On.

        These solutions will change Lesson's behavior so that it will more closely follow the description in the help files.

        Lets hear some feedback

        From Chris (chris.collman at granite.edu) Friday, 19 May 2006, 02:18 AM:

        am a bald guy of very little code brains However, anything I can do, give me a shout. Glad you were able to duplicate the problem.

        The forum post concerning turning off the display of number of questions answered is a different issue (I think).

        In a slightly related subject, I asked Helen how I could help with help files. She refered to some post between Martin and Gustav, so I tossed in my two cents worth. You just made another good point, which individual has the time to use every feature, test every help button even in one module, that is a lot of time. Cut and pasting somebody else's work is so much easier.

        From Mark Nielsen (man15 at humboldt.edu) Friday, 19 May 2006, 09:14 AM:

        1, 2 and 3 are fixed in MOODLE_16_STABLE and HEAD. Please test! And don't forget to update your lang file.

        Don't have time for these at the moment, so filed them as bugs

        4. MDL-5539

        5. MDL-5540

        From Chris (chris.collman at granite.edu) Friday, 19 May 2006, 09:31 AM:

        OK, I will do a little testing tomorrow morning with 1.6. I always download the entire package and unzip it, replacing all files. WinZip tells me it is replacing all the lang files and I've noticed it cures any issues I created with an attempted hack Thanks

        From Chris (chris.collman at granite.edu) Saturday, 20 May 2006, 10:26 PM:

        Lost the version of my lesson, had to modify an earlier backup. Sorry for the delay. I kept it simple and only sent the student back two pages on the 2nd and 5th question for a wrong answer, all other wrong answers was set to this page. Students had two attempts at any question. They had to view 4 question pages.

        Double checked my settings. I had custom scoring on max score was 6. Sorry, I thought I turned custom scoring off.

        I downloaded 1.6 Beta 5 2006050501 this morning from Moodle downloads, it was 8 hours old. My SOP is to unzip everything to c:/moodle16/moodle and tell it to replace all files.

        My daughter is home from college and is chomping at the bit for me to assist her in her roundtuit project - NOW. Yeah. Mark is first.

        Attempt A. I logged in as my student DimWit. DW made some misses on the 6 questions. DW made two attempts on the same lesson.

        1. I like the collapsed view the puts questions in red !

        2. I am still trying to get my head around the view pages and lesson settings min questions viewed.

        3.

        Here was the question progression and DW's

        Attempt A:

        q1w, q1c, q2w, q1c,q2c,q3c,q4w,q4w, q5c,q6w, q6w.

        Earned 4 points of 6, viewed 13 page needed to view 4, correct 4 (out of 6), Grade 1.8 (Out of 6). At end of LessonScore 3(out of 6) Grade is 3 (out of 6)

        Attempt B:

        q1w,q1c,q2w,q1c,q2c,q3c,q4w,q4w,q5c,q6w,q6w

        Earned 4 points of 6, viewed 11 page needed to view 4, correct 4 (out of 6), Grade 2.2 (Out of 6). At end of Lesson Score 4(out of 6), Grade 4 (out of 6).

        Attempt C: (custom scoring off) followed B progress

        q1w,q1c,q2w,q1c,q2c,q3c,q4w,q4w,q5c,q6w,q6w

        YOu have answered 4 correctly out of 6 question. Number pages viewed 11 (You should view 4). Correct answers 4, current grade 2.2 of 6. Humm why am I seeing a current grade when I turned off custom scoring, because I left 6 in Max grade, or is this a carryforward of DW's previous attempts.

        Got to deal with the daughter. I will return to this.

        Thanks for your efforts.

        Mark Nielsen added a comment -

        Haven't heard any complaints about this fix. Changing it to Resolved for now.

        Chris Collman added a comment -

        Mark, I agree, could be it was fixed in 1.6 . We are using a different solution to fight our speed clickers. We have shorter lessons, give students only one attempt at fewer questions with a higher percent pass required. They repeat the lesson and can not go on if they don't meet our standard.

        The question gets counted as an attempt when the response comes up.

        I must have missed how to close an issue before today. Otherwise I would have done it and not made the comment. Bald guys..... Thanks


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: