Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-54122

Deleting course does not delete preconfigured course-level LTI tools

    XMLWordPrintable

Details

    • Bug
    • Status: Open
    • Minor
    • Resolution: Unresolved
    • 3.0.4, 3.3.3, 3.4
    • None
    • MOODLE_30_STABLE, MOODLE_33_STABLE, MOODLE_34_STABLE

    Description

      1. Create course
      2. Add External tool, next to "Preconfigured tool" click "+" and fill the form, complete creating of external tool
      3. Add another external tool, make sure you can select this preconfigured tool and it is located under "Course tools" heading
      4. Check in the DB that you have entries in lti_types table pointing to this course
      5. Delete the course
      6. Check in the DB that you no longer have entries in lti_types table pointing to this course

      Last step currently fails.

      Another scenario:

      1. Repeat steps 1-4 above
      2. Restore another course backup into this course choosing to delete current course contents
      3. Add a new external tool and make sure there is nothing in preconfigured "Course tool" from before the restore

      P.S. course reset is also not implemented for External tools

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              marina Marina Glancy
              Ilya Tregubov, Kevin Percy, Mathew May, Mihail Geshoski, Shamim Rezaie
              Votes:
              4 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated: