Moodle
  1. Moodle
  2. MDL-5434

Theme logos are inaccessible - missing Alt text.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_16_STABLE
    • Rank:
      11443

      Description

      Keywords: accessibility, themes.

      Any themes that use logo images, 'formal_white' and 'standardlogo' in the main Moodle distribution, need Alt text which contains the same text as is in the image. This is a basic accessibility and XHTML validation error.

      Unfortunately the text may need to be hardcoded, as it is not the same as the $heading variable - see 'standardlogo' theme.

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Nick Freear (n.d.freear at open.ac.uk) Friday, 19 May 2006, 07:13 PM:

        Fixed on branch and merged. http://moodle.cvs.sourceforge.net/moodle/moodle/theme/formal_white/header.html, http://moodle.cvs.sourceforge.net/moodle/moodle/theme/standardlogo/header.html

        I've put a warning comment that the Alt text needs editing if the logo changes.

        Show
        Martin Dougiamas added a comment - From Nick Freear (n.d.freear at open.ac.uk) Friday, 19 May 2006, 07:13 PM: Fixed on branch and merged. http://moodle.cvs.sourceforge.net/moodle/moodle/theme/formal_white/header.html , http://moodle.cvs.sourceforge.net/moodle/moodle/theme/standardlogo/header.html I've put a warning comment that the Alt text needs editing if the logo changes.
        Hide
        Michael Blake added a comment -

        assign to a valid user

        Show
        Michael Blake added a comment - assign to a valid user

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: