Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-54553

Notices when webserver problem with behat

    Details

    • Testing Instructions:
      Hide
      1. Run behat on a small tag (e.g. @block_html)
      2. Verify that the behat run works, that the environment information is printed
      3. set your behat_wwwroot to something which doesn't match the moodle install, but does return a http response
      4. Run behat
      5. Verify that you get an error about site not available (" {yourbadbehatwwwroot} is not available, ensure you specified 'correct url and that the server is set up and started.") and the process stops.
        # set your behat_wwwroot to something which doesn't even resolve
        # Run behat
        # Verify that you get an error about site not available ("{yourbadbehatwwwroot}

        is not available, ensure you specified 'correct url and that the server is set up and started.") and the process stops.

      Show
      Run behat on a small tag (e.g. @block_html) Verify that the behat run works, that the environment information is printed set your behat_wwwroot to something which doesn't match the moodle install, but does return a http response Run behat Verify that you get an error about site not available (" {yourbadbehatwwwroot} is not available, ensure you specified 'correct url and that the server is set up and started.") and the process stops. # set your behat_wwwroot to something which doesn't even resolve # Run behat # Verify that you get an error about site not available ("{yourbadbehatwwwroot} is not available, ensure you specified 'correct url and that the server is set up and started.") and the process stops.
    • Affected Branches:
      MOODLE_30_STABLE, MOODLE_31_STABLE
    • Fixed Branches:
      MOODLE_30_STABLE
    • Pull Master Branch:
      MDL-54553-master

      Description

      A bit like MDL-53861:

      PHP Warning:  Invalid argument supplied for foreach() in /Users/danp/moodles/im_oracle/moodle/lib/behat/classes/util.php on line 168
      
      Warning: Invalid argument supplied for foreach() in /Users/danp/moodles/im_oracle/moodle/lib/behat/classes/util.php on line 168
      Differences detected between cli and webserver...
      Moodle 3.1beta+ (Build: 20160510), b0bb08bf8d34865c14ae820832e8c81b5b1232a3
      Php: 5.6.20, Oracle: 11.2.0.2.0, OS: Darwin 15.4.0 x86_64
      Server OS "Darwin", Browser: "firefox"
      Started at 12-05-2016, 20:08
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Jul/16