Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-54633

Required text field client side validation fails in TinyMCE

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Blocker
    • Resolution: Fixed
    • 3.1
    • 3.1
    • Forms Library

    Description

      This has been discovered by wuzi1999 while testing moodle.org 3.1 upgrade (MDLSITE-4521).

      Reproduce:

      1. Choose TinyMCE as you preferred editor
      2. Attempt to submit a text in the forum

      Expected behaviour: The text is posted when pressing the submit button.

      Actual behaviour: The first press of the submit button leads to false validation failure, marking the post text field as required even if the text is present there. Only the second press of the submit button actually submits the form.

      Reproduced by me on vanilla 3.1-rc1 installation.

      Attachments

        Issue Links

          Activity

            People

              mudrd8mz David Mudrák (@mudrd8mz)
              mudrd8mz David Mudrák (@mudrd8mz)
              David Monllaó David Monllaó
              Dan Poltawski Dan Poltawski
              Dan Poltawski Dan Poltawski
              David Woloszyn, Huong Nguyen, Jake Dallimore, Michael Hawkins, Stevani Andolo
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                23/May/16