Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-54729

Forum post deep link highlight does not work the first time in IE

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1, 3.1 regressions
    • Fix Version/s: 3.1.1
    • Component/s: Forum, HTML and CSS
    • Labels:
    • Testing Instructions:
      Hide

      Make sure to test this on all supported browsers. Specifically IE

      1. As an admin go to the preferences page and enter the forum preferences.
      2. Set 'Forum tracking' to 'Yes: highlight new posts for me'
      3. Create a forum.
      4. Have students make posts to the forum.
      5. Log in as the administrator.
      6. Click on the forum.
      7. There should be an 'Unread' column. Click the link there.
      8. You should be directed to the posts. The page should move to the anchor of the new post. This post should have a blue bar on the left. Subsequent posts will not have the blue bar but will have the yellow highlighting.
      Show
      Make sure to test this on all supported browsers. Specifically IE As an admin go to the preferences page and enter the forum preferences. Set 'Forum tracking' to 'Yes: highlight new posts for me' Create a forum. Have students make posts to the forum. Log in as the administrator. Click on the forum. There should be an 'Unread' column. Click the link there. You should be directed to the posts. The page should move to the anchor of the new post. This post should have a blue bar on the left. Subsequent posts will not have the blue bar but will have the yellow highlighting.
    • Affected Branches:
      MOODLE_31_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      wip-MDL-54729-master
    • Sprint:
      3.2 Sprint 1

      Description

      Reproduction steps (Use IE)

      1. Log in
      2. Enable forum tracking in user preferences ("Yes, highlight...")
      3. In another browser login as a different user
      4. Post in a forum where both users are enrolled
      5. On the first user, go to a forum where you have unread messages
      6. Click on the number (of unread posts) in the "Unread" column (NOT on the discussion title)

      Actual result (bug): No blue highlight is shown
      Expected result: A blue highlight is shown

      Test browser: IE11 windows 8.1

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              abgreeve Adrian Greeve
              Reporter:
              johno John Okely
              Peer reviewer:
              cameron1729
              Integrator:
              Dan Poltawski
              Tester:
              Rajesh Taneja
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Amy Groshek, David Scotson, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                11/Jul/16