Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-55120

Prepare Moodle for PHP 7.1

    XMLWordPrintable

    Details

    • Type: Epic
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.4, 3.1
    • Fix Version/s: 3.2
    • Component/s: General, Installation
    • Labels:
      None
    • Affected Branches:
      MOODLE_30_STABLE, MOODLE_31_STABLE
    • Fixed Branches:
      MOODLE_32_STABLE
    • Epic Name:
      Prepare Moodle for PHP7.1

      Description

      And again, more deprecations in the PHP language that moodle has to work with.

      PHP 7.1 is expected in December 2016, we should aim to make Moodle 3.2 compatible with it.

      https://wiki.php.net/rfc/deprecations_php_7_1

        Attachments

        1. phpunit71_20160831.txt
          30 kB
          Marina Glancy
        2. phpunit71_20160902.txt
          13 kB
          Marina Glancy

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              marina Marina Glancy
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Matteo Scaramuccia, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                5/Dec/16