Moodle
  1. Moodle
  2. MDL-5515

Not all indexes in the postgres7.sql files use the database prefix

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Environment:
      All
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_16_STABLE
    • Rank:
      11465

      Description

      This makes it impossible to have two moodle instances share one postgres database by using two different prefixes.

      Patch on the way.

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Tim Hunt (T.J.Hunt at open.ac.uk) Tuesday, 16 May 2006, 11:12 PM:

        OK so the attached patch would fix the problem if were were not in a DB freeze on the 1.6 trunk.

        Note also that the line

        CREATE INDEX post_module_idx ON prefix_post (module);

        was wrong. The column in that table is called moduleid. The patch fixes that too.

        From Tim Hunt (T.J.Hunt at open.ac.uk) Tuesday, 16 May 2006, 11:23 PM:

        First version of the patch was broken. Use the second one.

        From Gustav Delius (gwd2 at york.ac.uk) Wednesday, 17 May 2006, 03:31 AM:

        Tim, you asked in the forum why you could not assign this bug to yourself. The reason is that you had not been added as a developer to this bug tracker. I have now done that.

        Gustav

        From Eloy Lafuente (stronk7 at moodle.org) Wednesday, 17 May 2006, 11:24 PM:

        if I'm not wrong, ML has applied this patch against CVS, so this could be closed...isn't it?

        Ciao

        From Tim Hunt (T.J.Hunt at open.ac.uk) Wednesday, 17 May 2006, 11:29 PM:

        Not yet. He has rolled in into a bigger patch that will be applied on the branch soon.

        From Eloy Lafuente (stronk7 at moodle.org) Thursday, 18 May 2006, 12:50 AM:

        Oki! Waiting then...ciao

        From Martin Langhoff (martin at catalyst.net.nz) Thursday, 18 May 2006, 05:40 AM:

        In HEAD and MOODLE_16_STABLE!

        Show
        Martin Dougiamas added a comment - From Tim Hunt (T.J.Hunt at open.ac.uk) Tuesday, 16 May 2006, 11:12 PM: OK so the attached patch would fix the problem if were were not in a DB freeze on the 1.6 trunk. Note also that the line CREATE INDEX post_module_idx ON prefix_post (module); was wrong. The column in that table is called moduleid. The patch fixes that too. From Tim Hunt (T.J.Hunt at open.ac.uk) Tuesday, 16 May 2006, 11:23 PM: First version of the patch was broken. Use the second one. From Gustav Delius (gwd2 at york.ac.uk) Wednesday, 17 May 2006, 03:31 AM: Tim, you asked in the forum why you could not assign this bug to yourself. The reason is that you had not been added as a developer to this bug tracker. I have now done that. Gustav From Eloy Lafuente (stronk7 at moodle.org) Wednesday, 17 May 2006, 11:24 PM: if I'm not wrong, ML has applied this patch against CVS, so this could be closed...isn't it? Ciao From Tim Hunt (T.J.Hunt at open.ac.uk) Wednesday, 17 May 2006, 11:29 PM: Not yet. He has rolled in into a bigger patch that will be applied on the branch soon. From Eloy Lafuente (stronk7 at moodle.org) Thursday, 18 May 2006, 12:50 AM: Oki! Waiting then...ciao From Martin Langhoff (martin at catalyst.net.nz) Thursday, 18 May 2006, 05:40 AM: In HEAD and MOODLE_16_STABLE!
        Hide
        Michael Blake added a comment -

        assign to a valid user

        Show
        Michael Blake added a comment - assign to a valid user

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: