Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-55837

Deprecate "base and canvas" themes

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      1) If there is any base/canvas based theme installed in the site, both CLI and web upgrade won't happen, asking for the dependencies to be satisfied before continuing.
      2) If there isn't any base/canvas theme installed... upgrade will happen and there won't be anything to verify, but maybe check there aren't config settings belonging to those 2 themes.

      Show
      1) If there is any base/canvas based theme installed in the site, both CLI and web upgrade won't happen, asking for the dependencies to be satisfied before continuing. 2) If there isn't any base/canvas theme installed... upgrade will happen and there won't be anything to verify, but maybe check there aren't config settings belonging to those 2 themes.
    • Affected Branches:
      MOODLE_32_STABLE
    • Fixed Branches:
      MOODLE_32_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-55837-master

      Description

      Since we are adding a new theme in 3.2 and we don't test in base or canvas - we should deprecate them (move to plugins dir). I doubt base and canvas have aged well since we don't test in them and we have been adding bootstrap classes directly to the DOM for a while now.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                4 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/Dec/16