Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-55863

Upgrade notification does not warn about impossible upgrades (i.e. from 2.5 to 3.1)

    XMLWordPrintable

    Details

    • Affected Branches:
      MOODLE_31_STABLE
    • Story Points:
      3
    • Sprint:
      International 4.0 - Sprint 3

      Description

      It is not possible to upgrade from 2.5 directly to 3.1, however upgrade notifications in Moodle 2.5 suggest to upgrade to 3.1 and upgrade process later stops because it is unable to proceed.

      I'm not sure how/if we can change it for 2.5 and other unsupported versions but at least let's prevent it in the future for other breaks in upgrade paths

      See also
      https://moodle.org/mod/forum/discuss.php?d=339270

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              marina Marina Glancy
              Participants:
              Component watchers:
              Matteo Scaramuccia, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              4 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated: