Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-55989

edit/duplicate question (and maybe creation) url is wrong because of url encoding

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Not a bug
    • 3.1.2
    • None
    • Questions
    • MOODLE_31_STABLE

    Description

      having imported from a previous version (2.3.2) entire courses whit quiz and questions, being on questions repository and choosing a category

      domainname/question/edit.php?cmid=621&category=215%2C2055&qbshowtext=0&recurse=0&recurse=1&showhidden=0&showhidden=1
      

      every question edit/duplicate url is presented like this

      domainname/question/question.php?returnurl=%2Fquestion%2Fedit.php%3Fcmid%3D621%26cat%3D215%252C2055%26qpage%3D0%26recurse%3D1%26showhidden%3D1%26qbshowtext%3D0&cmid=621&id=2824
      

      the url is wrong and the link leads to Dashboard; the problem seems to reside in the value of the "cat" parameter, which in this example is 215,2055: in first place it becomes 215%2C2055 then again encoded in 215%252C2055 (% of the first %2C enconding is encoded again);

      in some cases, the "cat" parameter is encoded only once (eg. 215%2C2055), but the link leads always to Dashboard;

      preview and delete urls are working correctly (besides the same "cat" parameter encoding);

      the same behaviour could affect question creation because after chosing the question type (eg. true/false) in the modal popup redirection leads to Dashboard instead of proceeding

      Attachments

        Activity

          People

            timhunt Tim Hunt
            jami Daniele Conca
            Tim Hunt, Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: