XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.2
    • Fix Version/s: None
    • Component/s: Enrolments, LTI provider
    • Labels:

      Description

      • Remove enrol_lti_item table
      • Use $this->user->image for user_image
      • Make sure 'failed registration’ language string isn’t used for launches.
      • Should we save tool proxy to the db? No
      • Register a user as student when role is incorrect or not sent (what happens currently? It just says Sorry, there was an error connecting you to the application.)
      • Make a nicer error message if no resource_link_id is given
      • Most errors are not using notification API (wrong url, wrong parameters) mod_lti is doing this. No need to fix
      • Fix bug where enrol_lti_lti2_nonce is not working without auto increment id.

        to avoid an error unknown error fetching inserted id I have to and id autoincrement

        Unable to reproduce
      • Fix all code style errors that have snuck through
      • If no return url is given, it should still work (add unit test to cover this) - Required in spec
      • Fix todos

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              johno John Okely
              Reporter:
              johno John Okely
              Peer reviewer:
              Jun Pataleta
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón, Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: