Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-56113

Debugging: Context was already set in init() method, ignoring context parameter

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.1.1
    • Fix Version/s: None
    • Component/s: Web Services
    • Labels:
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_31_STABLE

      Description

      Found while reviewing my server error logs (with the site set to developer debug)

      php[4920]
      Debugging: Context was already set in init() method, ignoring context parameter in

      • line 204 of \lib\classes\event\base.php: call to debugging()
      • line 1034 of \webservice\lib.php: call to core\event\base::create()
      • line 921 of \webservice\lib.php: call to webservice_server->authenticate_by_token()
      • line 1184 of \webservice\lib.php: call to webservice_server->authenticate_user()
      • line 44 of \webservice\rest\server.php: call to webservice_base_server->run()

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            sbourget Stephen Bourget
            Participants:
            Component watchers:
            Juan Leyva, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated: